Advanced Search

HTTPS coming soon

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #42229
    developer (ChrisB)
    Keymaster
    • Topics: 51
    • Replies: 259

    We’re planning to implement HTTPS (encryption, aka SSL) on the forum soon. This should be a non-event that users won’t even notice, but in the event we have issues, we’ll roll-back to regular http, fix whatever went wrong, and then implement it again.

    We are doing pre-release testing to try and prevent errors, but every release tends to come with its own curveballs.

    Working to make knife.wickededgeusa.com a great forum!

    3 users thanked author for this post.
    #42231
    MarcH
    Moderator
    • Topics: 59
    • Replies: 2020

    What are the advantages of an encrypted forum.  Please forgive my lack of computer knowledge.

    Marc
    (MarcH's Rack-It)

    1 user thanked author for this post.
    #42240
    Mark76
    Participant
    • Topics: 179
    • Replies: 2760

    Thanks, that’s useful! Marc, for example, user names, passwords and other sensitive information will be encrypted over the internet. Also, if you use an insecure Wifi hotspot, your information cannot be listened in on there. Moreover, companies like Google are really pressing sites to use https only; in the future they might even block sites that use http only.

    Molecule Polishing: my blog about sharpening with the Wicked Edge

    3 users thanked author for this post.
    #42268
    developer (ChrisB)
    Keymaster
    • Topics: 51
    • Replies: 259

    Thanks, that’s useful! Marc, for example, user names, passwords and other sensitive information will be encrypted over the internet. Also, if you use an insecure Wifi hotspot, your information cannot be listened in on there. Moreover, companies like Google are really pressing sites to use https only; in the future they might even block sites that use http only.

    Mark76 – Perfect answer, thank you!

    Working to make knife.wickededgeusa.com a great forum!

    #42350
    developer (ChrisB)
    Keymaster
    • Topics: 51
    • Replies: 259

    OK, we’re up-and-running with a secure (encrypted) forum now! So far, it seems like a non-event, which is always nice when it works out that way. Just let me know if it causes any snags for you.

    2017-11-28_18-09-27

    Working to make knife.wickededgeusa.com a great forum!

    Attachments:
    1 user thanked author for this post.
    #42355
    Mark76
    Participant
    • Topics: 179
    • Replies: 2760

    Congrats! I just logged in, but it seems to be working fine.

    And, it’s another topic and I already sent you an email about it, but weird things seem to be happening at the forum. Could you take a look at the message following this link: https://knife.wickededgeusa.com/forums/topic/interested-help-narrowing-it-down-please/#post-42333

    Molecule Polishing: my blog about sharpening with the Wicked Edge

    1 user thanked author for this post.
    #42367
    developer (ChrisB)
    Keymaster
    • Topics: 51
    • Replies: 259

    Congrats! I just logged in, but it seems to be working fine. And, it’s another topic and I already sent you an email about it, but weird things seem to be happening at the forum. Could you take a look at the message following this link: https://knife.wickededgeusa.com/forums/topic/interested-help-narrowing-it-down-please/#post-42333

    Thanks Mark, we’re looking into that issue, and I replied by email. I’ll probably create a new thread to provide an update, once we have it ready.

    Working to make knife.wickededgeusa.com a great forum!

    #42402
    Mark76
    Participant
    • Topics: 179
    • Replies: 2760

    Chris, thanks for your efforts! And thanks for the mail.

    I think we identified two separate problems:

    • messages sometimes disappearing and even less often (in the case of Tom’s message with the pink background) temporarily reappearing;
    • being logged out when going to the private messages.

    As I wrote in the other topic (I’ll stop mixing up topics, though I’m afraid I’m polluting another topic now…) on the first issue:

    My first guess is that this is a consequence of an anti-spam setting we use. It prevents spammers from rapid-fire pasting the same comment in multiple topics or replies. So, I think there’s a “cooling off” period that requires a couple minute wait (I’ll look it up, for the exact time) before you’re allowed to post the same reply, even if it’s a completely legitimate edited reply.

    I never noticed this anti-spam setting. In fact, it happens to me once in a while that I press “Submit” after typing a new message, but that the server (or my internet connection) is slow, so that the message doesn’t appear within a few seconds. I then think I may have mis-clicked the button and press “Submit” again. The end result is that my message is posted twice.

    The second problem, me having problems with private messages (getting logged out when I press Forum -> My Private Messages) is still there, due to which I cannot read or write private messages. It happens with all browsers (Chrome, Edge, IE) and all computers I’ve tried.

    The problem Tom and Marc had with messages disappearing was there before the switch to https, so it’s unlikely that these two are related. But me being logged out when trying to post a private message first occurred on the day we switched to https. Could this be related? I also noted that the PM-page does not support https yet (I think). And do more people have this problem?

    Molecule Polishing: my blog about sharpening with the Wicked Edge

    1 user thanked author for this post.
    #42406
    developer (ChrisB)
    Keymaster
    • Topics: 51
    • Replies: 259

    The second problem, me having problems with private messages (getting logged out when I press Forum -> My Private Messages) is still there, due to which I cannot read or write private messages. It happens with all browsers (Chrome, Edge, IE) and all computers I’ve tried. The problem Tom and Marc had with messages disappearing was there before the switch to https, so it’s unlikely that these two are related. But me being logged out when trying to post a private message first occurred on the day we switched to https. Could this be related? I also noted that the PM-page does not support https yet (I think). And do more people have this problem?

    Thanks for the heads up on Private Message problems! One aspect of it should be a quick fix – making sure it’s always on https. You’ll notice now that if you manually change the URL to https (from http) it works, and all the PMs are there. But it should happen automatically.

    Working to make knife.wickededgeusa.com a great forum!

    #42414
    developer (ChrisB)
    Keymaster
    • Topics: 51
    • Replies: 259

    Private Messages (PMs) should be working now, apologies for the problems there. Somehow the URL for PMs wasn’t being redirected to https properly, but now it is.

    Working to make knife.wickededgeusa.com a great forum!

    1 user thanked author for this post.
    #42419
    Mark76
    Participant
    • Topics: 179
    • Replies: 2760

    Yeah, it works. Thanks!

    Molecule Polishing: my blog about sharpening with the Wicked Edge

    1 user thanked author for this post.
Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.